AVC

在 ISR1900/2900/3900/4300/4400 路由器上启用 AVC 功能,必须具备 DATA License 或 APP License。(可以从 show license 看到)

最简单的启用方式称为 ezPM,即 Easy Performance Monitor。配置方式如下,其中 MyAVC 是自定义名称、AVC分析结果由Gi0/0/0送出、至10.1.1.1 端口9991 (报表软件的地址与端口)。

如果使用 Cisco Prime Infrastructure 作为报表软件,缺省端口是9991;如果使用 Plixer 作为报表软件,缺省端口为 9996。

performance monitor context MyAVC profile application-experience
 exporter destination 10.1.1.1 source Gi0/0/0 port 9991
 traffic-monitor all
!
interface gi0/0/0
 performance monitor context MyAVC
!

如果搭配 Prime Infrastructure 3.0 版以上,建议在路由器上使用 IOS XE 3.16 或 IOS 15.5 以上,并配合以下修改过的 ezPM 配置,会有更佳的报表效果。

ip access-list extended business-critical-and-default-tcp-only
 permit tcp any any
ip access-list extended business-critical-and-default-udp-only
 permit udp any any
!
class-map match-any Scavenger
 match protocol attribute category social-networking
 match protocol attribute category gaming
 match protocol attribute category consumer-internet
 match protocol attribute category consumer-messaging
 match protocol attribute category consumer-streaming
 match protocol attribute category instant-messaging
 match protocol attribute category consumer-file-sharing
! 
class-map match-any business-critical-and-default
 match protocol attribute category inter-process-rpc
 match protocol attribute category industrial-protocols
 match protocol attribute category net-admin
 match protocol attribute category voice-and-video
 match protocol attribute category email
 match protocol attribute category layer3-over-ip
 match protocol attribute category backup-and-storage
 match protocol attribute category epayement
 match protocol attribute category anonymizers
 match protocol attribute category browsing
 match protocol attribute category other
 match protocol attribute category software-updates
 match protocol attribute category business-and-productivity-tools
 match protocol attribute category trojan
 match protocol attribute category file-sharing
 match protocol attribute category database
!
class-map match-all Business-Critical-and-default-tcp-only
 match class-map business-critical-and-default
 match access-group name business-critical-and-default-tcp-only
class-map match-all Business-Critical-and-default-udp-only
 match class-map business-critical-and-default
 match access-group name business-critical-and-default-udp-only
class-map match-any Http-class
 match protocol http
!
performance monitor context MyAVC profile application-experience
 exporter destination 10.1.1.1 source Gi0/0/0 transport udp port 9991 
 traffic-monitor application-response-time class-replace Business-Critical-and-default-tcp-only
 traffic-monitor media class-replace Business-Critical-and-default-udp-only
 traffic-monitor url class-replace Http-class
 traffic-monitor conversation-traffic-stats class-replace Scavenger
!
interface GigabitEthernet0/0/0
 performance monitor context MyAVC
!
除非特别注明,本页内容采用以下授权方式: Creative Commons Attribution-ShareAlike 3.0 License