DMVPN 基础配置

配置说明 | 验证配置 | 测试效果


dmvpn-config.jpg

总部

interface Tunnel0
 ip address 172.30.10.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip tcp adjust-mss 1360
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip nhrp shortcut
 ip nhrp redirect
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint

分支机构

interface Tunnel0
 ip address 172.30.10.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip tcp adjust-mss 1360
 ip nhrp map 172.30.10.1 1.1.1.1
 ip nhrp map multicast 1.1.1.1
 ip nhrp network-id 1
 ip nhrp nhs 172.30.10.1
 ip nhrp registration no-unique
 ip nhrp shortcut
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint

在总部仅需配置一个mGRE接口,即可连接来自所有分支机构的 tunnel。

在分支机构的 NHRP 配置中,须指定总部公网地址(本例中为 1.1.1.1),但不须明确指定本地公网地址,因此只有总部需要有固定的公网地址,分支机构可以使用变动的公网或私网地址。

小提示:IP、GRE、与IPSec标头会造成 IP 包增大,须用 ip mtu 1400 来指定离开 tunnel 时的 IP 包大小上限。

小提示:配置路由时须注意,只有需要走在 tunnel 里面的包,下一跳应配置为 tunnel 端口,不需要走在 tunnel 里的包,特别是建立 tunnel 的包,下一跳应为实体端口的网关。所以最好不要把 default route 的下一跳配置为 tunnel 端口。

除非特别注明,本页内容采用以下授权方式: Creative Commons Attribution-ShareAlike 3.0 License