Performance Routing Version 3
pfr.png

相较于之前版本的PfR而言,PfRv3最大的好处就是增加了控制全网路由的Hub Master角色,以集中管理的方式,大幅降低所需的配置数量。然而产生的最大限制,就是必须要配合DMVPN使用。

PfR v1 PfR v2 PfR v3
IOS IOS 12.3(8)T, XE 2.6.1 IOS 15.2(3)T, XE 3.6 IOS 15.4(3)M, XE 3.13
设备配置 每台设备独立配置 每台设备独立配置 基于PfR域的配置
策略配置 每个功能都要配置 多个功能整合在一起 只需在 Hub Master 配置策略
断线切换 6 秒 6 秒 小于 1 秒
策略触发切换 9 秒 9 秒 2 秒
支持分支数量 ~10家 500 家 2000 家

英文官方配置手册:连结


功能

  • 依据 DSCP 值与 AVC 识别出来的应用名称,对流量进行分类(Class),一般建议分成三到五类。
  • 每个应用可以有自己的切换策略。切换策略的内容包含 latency、packet loss rate、byte loss rate、与 jitter 的优先级与限制。
  • 对每个类(Class)可以配置优先的路径,与违反策略时要切换的路径。也可以配置成负载均衡。

角色

  • Master Hub:位于总部,控制全网路由策略配置与总部的策略执行。通常是一台独立的路由器,但如果分支机构非常少,也可以跟某一个 Border Router 是公用一台路由器。
  • Master Branch:位于分公司,控制该分公司内路由策略的执行,通常与分公司的某一个 Border Router 共用一台路由器。
  • Border Router:连接线路的路由器。总部端,原则上每条WAN线路需使用一台路由器;分公司端,则可以把多条线路接在同一台路由器上。

Hub R1 配置

端口配置

  • Tunnel 11:从 WAN port 出去的 DMVPN Tunnel
  • Loopback47233:PfR 路由器之间沟通使用的端口
  • Tunnel47233:两台 Hub Border Router 之间传送流量的Tunnel
interface Tunnel11
 < 此处省略 DMVPN 配置 >
 domain ONE path INET1 path-id 11
!
interface Loopback47233
 ip address 172.20.0.129 255.255.255.255
 ip pim sparse-mode
!
interface Tunnel47233
 ip address 192.168.2.1 255.255.255.252
 keepalive 5 3
 tunnel source 172.20.0.129
 tunnel destination 172.20.0.130

Hub 端,基本 Master Hub 配置

  • DC-PREFIX:Hub 端需要PfR起作用的 LAN 网段
  • ENTERPRISE-PREFIXES:整个公司的网段,像是DC-PREFIX、分公司里需要PfR起作用的LAN网段、DMVPN Tunnel、Loopback等。不在这个 prefix 里的网段,都是为外部 Internet 地址。
  • Collector 指的是 Prime Infrastructure 3.1 的地址,可以显示 PfR 的状态
domain ONE
 vrf default
  master hub
   source-interface Loopback47233
   site-prefixes prefix-list DC-PREFIX
   enterprise-prefix  prefix-list ENTERPRISE-PREFIXES
   load-balance
   advanced
    channel-unreachable-timer 4
   collector x.x.x.x port 9991
   < class 流量类别配置:一般建议区分三到五类,参考配置如后 >

Class 流量类别配置

  • 每个类别包含哪些应用,并套用哪个policy (此处例子中都是内建的policy,也可以自定义policy),内建 policy包括 Voice、Real-time-video、Low-latency-data、Bulk-data、Best-effort、Scavenger,策略内容请参照官方文件:连结
  • 每个类别优先走哪条路:点选下方「 展开 Class 配置范例 」

Hub 端 Border Router 配置

  • master 命令指向 master hub 的 IP 地址,如果 master hub 跟 Border Router 是同一台,可以用关键字 local 指向自己
domain ONE
 vrf default
  border
   source-interface Loopback47233
   master local

Hub R2 配置

端口配置

  • Tunnel 10:从 WAN port 出去的 DMVPN Tunnel
  • Loopback47233:PfR 路由器之间沟通使用的端口
  • Tunnel47233:两台 Hub Border Router 之间传送流量的Tunnel
interface Loopback47233
 ip address 172.20.0.130 255.255.255.255
 ip pim sparse-mode
!
interface Tunnel10
  domain ONE path INET2 path-id 10
!
interface Tunnel47233
 ip address 192.168.2.2 255.255.255.252
 keepalive 5 3
 tunnel source 172.20.0.130
 tunnel destination 172.20.0.129

Hub 端 Border Router 配置

  • master 命令指向 master hub 的 IP 地址
domain ONE
 vrf default
  border
   source-interface Loopback47233
   master 172.20.0.129

Branch 分公司端路由器配置

端口配置

  • Loopback47233:PfR 路由器之间沟通使用的端口
  • 不需为 Tunnel 端口命名,因为 DMVPN 连到哪一台 Hub,就是继承那个名称(例如上述 INET1、INET2)
interface Loopback47233
 ip address 172.20.1.1 255.255.255.255
 ip pim sparse-mode
 hold-queue 1024 in
 hold-queue 1024 out

Spoke 端 Master Branch 配置

  • master 命令指向 master branch 的 IP 地址,如果 Master Branch 跟 Border Router 是同一台,可以用关键字 local 指向自己(如下)
domain ONE
 vrf default
  master branch
   source-interface Loopback47233
   hub 172.20.0.129

Spoke 端 Border Router 配置

  • master 命令指向 master branch 的 IP 地址,如果 Master Branch 跟 Border Router 是同一台,可以用关键字 local 指向自己(如下)
domain ONE
 vrf default
  border
   source-interface Loopback47233
   master local
除非特别注明,本页内容采用以下授权方式: Creative Commons Attribution-ShareAlike 3.0 License