配置 AppNav

配置 vCM | 配置 vWAAS | 配置 AppNav | 配置 WCCP | 版本升级 | 验证配置 | 测试效果 | 常见问题


waas-config.jpg

配置思科 ISR 4300/4400 与 ASR1000 路由器上的 AppNav

原理:

  • service-insertion service-node-group WAAS-SNG 是WAAS的群组
  • service-insertion appnav-controller-group WAAS-SCG 是具备AppNav功能的路由器的群组
  • service-insertion service-context waas/1 把WAAS群组、AppNav路由器群组、和路由器发送哪些流量到WAAS的Policy,绑定在一起。
  • service-insertion waas 表示这个端口是启用WAAS的WAN端口。
  • ip access-list extended SN_OR_WCM 是WAAS和CM的IP,这些 IP 不做优化。
ip access-list extended SN_OR_WCM
 permit tcp host CM的IP any
 permit tcp any host CM的IP
 permit tcp host 本地WAAS的IP any
 permit tcp any host 本地WAAS的IP
!
ip access-list extended WAAS
 permit tcp any any
ip access-list extended CIFS
 permit tcp any any eq 139
 permit tcp any any eq 445
ip access-list extended Citrix-CGP
 permit tcp any any eq 2598
ip access-list extended Citrix-ICA
 permit tcp any any eq 1494
ip access-list extended EPMAP
 permit tcp any any eq msrpc
ip access-list extended HTTP
 permit tcp any any eq www
 permit tcp any any eq 3218
 permit tcp any any eq 8000
 permit tcp any any eq 8080
 permit tcp any any eq 8088
ip access-list extended HTTPS
 permit tcp any any eq 443
ip access-list extended NFS
 permit tcp any any eq 2049
ip access-list extended RTSP
 permit tcp any any eq 554
 permit tcp any any eq 8554
!
class-map type appnav match-any RTSP
 match access-group name RTSP
class-map type appnav match-any WAAS
 match access-group name WAAS
class-map type appnav match-any MAPI
 match protocol mapi
class-map type appnav match-any HTTP
 match access-group name HTTP
class-map type appnav match-any CIFS
 match access-group name CIFS
class-map type appnav match-any Citrix-CGP
 match access-group name Citrix-CGP
class-map type appnav match-any EPMAP
 match access-group name EPMAP
class-map type appnav match-any HTTPS
 match access-group name HTTPS
class-map type appnav match-any SN_OR_WCM
 match access-group name SN_OR_WCM
class-map type appnav match-any NFS
 match access-group name NFS
class-map type appnav match-any Citrix-ICA
 match access-group name Citrix-ICA
!
policy-map type appnav WAAS
 description WAAS global policy
 class SN_OR_WCM
  pass-through
 class HTTP
  distribute service-node-group WAAS-SNG
  monitor-load http
 class MAPI
  distribute service-node-group WAAS-SNG
  monitor-load mapi
 class HTTPS
  distribute service-node-group WAAS-SNG
  monitor-load ssl
 class CIFS
  distribute service-node-group WAAS-SNG
  monitor-load cifs
 class Citrix-ICA
  distribute service-node-group WAAS-SNG
  monitor-load ica
 class Citrix-CGP
  distribute service-node-group WAAS-SNG
  monitor-load ica
 class EPMAP
  distribute service-node-group WAAS-SNG
  monitor-load MS-port-mapper
 class NFS
  distribute service-node-group WAAS-SNG
  monitor-load nfs
 class WAAS
  distribute service-node-group WAAS-SNG
!
service-insertion service-node-group WAAS-SNG
  service-node 本地WAAS的IP 
! 
service-insertion appnav-controller-group WAAS-SCG
  appnav-controller 路由器上用来发送流量到WAAS的端口IP(通常是LAN端口)
! 
service-insertion service-context waas/1
  appnav-controller-group WAAS-SCG
  service-node-group WAAS-SNG
  service-policy WAAS
  vrf default
  enable
! 要优化的WAN端口
interface GigabitEthernet0/0/1
 service-insertion waas
!
interface Tunnel10
 service-insertion waas
!

两台路由器的配置

如果同一个站点有两台路由器和两台WAAS,不管是独立运作的 WAVE/vWAAS 或是安装在 ISR4000 里的 ISR-WAAS,为了避免流量来回不同路(非对称路由),造成从一台WAAS出去,从另一台WAAS回来,导致优化失败,必须把 AppNav 配置成 Cluster 模式。

需要改变的配置只有 service-insertion service-node-group 和 service-insertion appnav-controller-group,修改范例如下:

service-insertion service-node-group WAAS-SNG
  service-node 本地WAAS的IP 
  service-node 本地另一台WAAS的IP
! 
service-insertion appnav-controller-group WAAS-SCG
  appnav-controller 路由器上用来发送流量到WAAS的端口IP(通常是LAN端口)
  appnav-controller 另一台路由器上用来发送流量到WAAS的端口IP(通常是LAN端口)
除非特别注明,本页内容采用以下授权方式: Creative Commons Attribution-ShareAlike 3.0 License